Skip to main content

Creating a Diffuse Map

To create a diffuse map:

  1. Open the scanned fabric image in Photoshop.

    Scanned fabric image

  2. If rulers are hidden, on the Main menu, click View > Rulers.

  3. Drag a horizontal and vertical guide from the rulers at the top and left-hand side onto the image. Use these guides as a reference.

  4. Using the horizontal and vertical guides, check if the grain is straight in the X and Y axis. If the grain line looks correct, go to step 5. If the grain line does not look correct:

    1. Double-click the background layer to unlock the layer.

    2. On the Main menu, click Edit > Transform > Rotate.

    3. Rotate the image until the grain line looks straight in both the X and Y axis in relation to the guide lines.

  5. Using the crop tool, crop the image as needed.

    If creating a diffuse map for a printed fabric, make sure one entire portion of the repeating print is inside the image frame to ensure a seamless repeating texture.
  6. On the Main menu, click Filter > Other > Offset. This function allows you to bring the image seams (edges) to the center so the repeat can be seen.

    Offset

  7. Move the slider for horizontal and vertical settings to see the image seam (edge) position change. Set it so that the seams show at the center of the image.

    Offset

  8. Open the clone tool, and set the brush size to be the size of a single repeat.

  9. Use the clone tool to set the selection region of the image seam (edge). Click and paint using the clone tool over the image seam (edge) area to remove any hard transition. Ensure there are no distinguishing marks within the repeat such as loose threads, specks, and so on.

    Some types of fabrics may require more work. For more complex fabrics, work with a smaller image region to ensure a seamless repeat.
  10. Paint over image seams (edges) until there is no noticeable seam. The weave in the image should now look seamless.

    Seamless weave in image

  11. Save and test this diffuse image by assigning it to a garment. If done correctly, the results should appear seamless on the simulated garment.

  12. If the diffuse texture looks correct in 3D, save the file as <filename>_col in your preferred file format. For example, seersucker_col. The correct name suffix is essential.

If creating a fabric with holes such as mesh, lace, and so on, select the holes within the repeat and delete the background texture. Save the file as a PNG to maintain a transparent background upon import to VStitcher.

© Browzwear Solutions Pte. Ltd. 2018-2021. All rights reserved. Legal Notices

Was this article helpful?
0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.

Articles in this section